← Back to roles

WLAN Test - Engineer

Qualcomm Technologies, Inc.

Chennai, Tamil Nādu, IndiaPosted Nov 14, 2026
Apply on Qualcomm Technologies, Inc.

Overview

Open roles
1,983
At this company
See all
Added in 30 days
454
At this company, still open

Skills named in this posting

  • Python
  • Perl
Company: Qualcomm India Private Limited Job Area: Engineering Group, Engineering Group > Systems Test Engineering General Summary: Automation Scripting Knowledge of Automation Scripts is mandatory – Python / Perl / TCL Traffic Analyzers Wireshark, Ethereal, airopeak/omnipeak Technologies with sound knowledge GPON/XGS-PON/L2/L3 network protocol Test experience with minimum of 1 to 5 years WLAN Testing (added advantage) Independent Project handling with analytical ability Testing Experience Functional and Performance Experience in Broadband technologies (GPON,XGS-PON,OLT, ONT) L2/L3 network protocol Have worked on testing of ONT/OLT products. Protocols/Layers with good theoretical & practical knowledge Sound knowledge on L2/L3 network protocol : TCP/IP, NAT,IGMP, QOS, DHCP, VLAN, PPPoE, PON: GEM Frame, T-CONT,GEM Ports, QoS, GPON, XGSPON WLAN: Basic Knowledge on WLAN Traffic Generators Understating and Usage of Traffic generator tools like OLT / ONU / Spirent / Ixia / Chariot/ Veriwave. Knowledge on RFC2544, RFC2889, RFC3918 tests etc. Operating Systems Windows 10/XP/Win7, Linux Minimum Qualifications: • Bachelor's degree in Engineering, Information Systems, Computer Science, or related field. Applicants: Qualcomm is an equal opportunity employer. If you are an individual with a disability and need an accommodation during the application/hiring process, rest assured that Qualcomm is committed to providing an accessible process. You may e-mail disability-accomodations@qualcomm.com or call Qualcomm's toll-free number found here. Upon request, Qualcomm will provide reasonable accommodations to support individuals with disabilities to be able participate in the hiring process. Qualcomm is also committed to making our workplace accessible for individuals with disabilities. (Keep in mind that this email address is used to provide reasonable accommodations for individuals with disabilities. We will not respond here to requests for updates on applications or resume inquiries). Qualcomm expects its employees to abide by all applicable policies and procedures, including but not limited to security and other requirements regarding protection of Company confidential information and other confidential and/or proprietary information, to the extent those requirements are permissible under applicable law. To all Staffing and Recruiting Agencies: Our Careers Site is only for individuals seeking a job at Qualcomm. Staffing and recruiting agencies and individuals being represented by an agency are not authorized to use this site or to submit profiles, applications or resumes, and any such submissions will be considered unsolicited. Qualcomm does not accept unsolicited resumes or applications from agencies. Please do not forward resumes to our jobs alias, Qualcomm employees or any other company location. Qualcomm is not responsible for any fees related to unsolicited resumes/applications. If you would like more information about this role, please contact Qualcomm Careers.

Apply on the employer's site

Original posting: careers.qualcomm.com

Apply on Qualcomm Technologies, Inc.

RISC-V ecosystem

Qualcomm Technologies, Inc. in the RISC-V ecosystem

RISC-V International: Premier Board

Founded in 1985, QUALCOMM is a global semiconductor company, known for designing, manufacturing, and marketing digital wireless communications equipment and services.

  • Qualcomm is one of five industry players that jointly formed Quintauris to strengthen the RISC-V hardware ecosystem
  • Adopted RISC-V for its next-generation Snapdragon Wear platform and is bringing a RISC-V based wearable platform to Wear OS by Google
  • Long-standing contributor to RISC-V specification/profile discussions

Same employer

View all 1,983